Xcode 9 and Xcode 10 Side-by-side

I have been working on Ionic 4 project recently and I hit to wall because since Cordova has compatibly issues with the latest Xcode (10). After headaches with compiling the iOS project I returned to great Ionic documentation about iOS setup where it of course clearly says on the top:

We recommend using XCode 9. Xcode 10 support in Cordova is still a work-in-progress. See this issue for details.

So, yes. You need Xcode 9 if you want to work on Corova still (as writing in Feb 8 2019.) Luckily it is possible to run multiple versions of Xcode on the same machine. You simply need to copy additional versions to Applications with different name. Like this:

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s